openrisc architecture · Maintained
Maintainers
- M Jonas Bonn <jonas@southpole.se>
- M Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
- M Stafford Horne <shorne@gmail.com>
Paths
- F
Documentation/arch/openrisc/ - F
Documentation/devicetree/bindings/openrisc/ - F
arch/openrisc/ - F
drivers/irqchip/irq-ompic.c - F
drivers/irqchip/irq-or1k-*
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-alpha (capped at 30), ordered by date desc.
-
STALE75d
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE131d
[PATCH] kbuild: Split .modinfo out from ELF_DETAILS
2026-02-25 · Nathan Chancellor <nathan@kernel.org> -
STALE74d
REVIEWED: 12 (12M) [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
2026-02-11 · Mike Rapoport <rppt@kernel.org> -
STALE140d
REVIEWED: 5 (5M) [PATCH v2 3/4] arch, mm: consolidate empty_zero_page
2026-02-09 · Mike Rapoport <rppt@kernel.org> -
STALE154d
[PATCH mm-unstable] arch, mm: consolidate empty_zero_page
2026-01-24 · Mike Rapoport <rppt@kernel.org> -
STALE125d
[PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE125d
REVIEWED: 1 (1M) [PATCH v3 13/29] openrisc: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE176d
[PATCH] mm/pgtable: convert pgtable_t to ptdesc pointer
2026-01-07 · alexs@kernel.org -
STALE143d
[PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE143d
[PATCH v2 12/28] openrisc: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE192d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE192d
[PATCH 12/28] openrisc: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE276d
[PATCH RESEND 61/62] init: rename CONFIG_RD_LZ4 to CONFIG_INITRAMFS_DECOMPRESS_LZ4
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 60/62] init: rename CONFIG_RD_LZO to CONFIG_INITRAMFS_DECOMPRESS_LZO
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 59/62] init: rename CONFIG_RD_XZ to CONFIG_INITRAMFS_DECOMPRESS_XZ
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 58/62] init: rename CONFIG_RD_LZMA to CONFIG_INITRAMFS_DECOMPRESS_LZMA
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 57/62] init: rename CONFIG_RD_BZIP2 to CONFIG_INITRAMFS_DECOMPRESS_BZIP2
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 31/62] init: rename initrd_below_start_ok to initramfs_below_start_ok
2025-09-13 · Askar Safin <hidden> -
STALE276d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE301d
[PATCH 3/6][openrisc] SET_PAGE_DIR() users had been gone since 2.3.12pre1
2025-09-11 · Al Viro <viro@zeniv.linux.org.uk> -
STALE301d
[PATCH 2/6][alpha,m68k,openrisc] PAGE_PTR() had been last used outside of arch/* in 1.1.94
2025-09-11 · Al Viro <viro@zeniv.linux.org.uk> -
STALE298d
LANDED [PATCH v2 3/4] arch: copy_thread: pass clone_flags as u64
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE267d
LANDED [PATCH 10/17] openrisc: Add __attribute_const__ to ffs()-family implementations
2025-08-04 · Kees Cook <kees@kernel.org> -
STALE361d
[PATCH 1/1] uapi/termios: remove struct ktermios from uapi headers
2025-07-16 · "H. Peter Anvin" <hpa@zytor.com> -
STALE398d
[PATCH 2/2] arch: use always-$(KBUILD_BUILTIN) for vmlinux.lds
2025-06-02 · Masahiro Yamada <masahiroy@kernel.org> -
STALE420d
[PATCH v2 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE420d
[PATCH v2 10/13] arch, mm: set high_memory in free_area_init()
2025-03-13 · Mike Rapoport <rppt@kernel.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE192d
[PATCH 12/28] openrisc: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE192d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org>